Заметки из Зазеркалья

18.05.2018

Улучшение работы с файлами в веб-клиенте

Данная статья является анонсом новой функциональности.
Не рекомендуется использовать содержание данной статьи для освоения новой функциональности.
Полное описание новой функциональности будет приведено в документации к соответствующей версии.
Полный список изменений в новой версии приводится в файле v8Update.htm.

Реализовано в версии 8.3.13.1513.

Мы расширяем возможности работы с файлами в веб-клиенте. Мы реализовали перетаскивание файлов «извне» и увеличили возможности, доступные без установки специального расширения работы с файлами.

Метод НачатьПомещениеФайлов() больше не требует расширения работы с файлами

Раньше для загрузки нескольких файлов вы могли выбрать один из двух способов: либо загружать каждый файл по отдельности, с помощью метода НачатьПомещениеФайла(), либо загрузить все файлы вместе методом НачатьПомещениеФайлов(). Но последний метод работал только в том случае, если заранее было установлено расширение работы с файлами, что не очень удобно.

Теперь мы «научили» метод НачатьПомещениеФайлов() работать и без расширения. При этом он использует новый «собственный» диалог выбора файлов, который позволяет выбирать сразу несколько файлов. Если расширение работы с файлами установлено, тогда используется диалог выбора файлов операционной системы.

Новый диалог выбора файлов

Мы значительно изменили диалог выбора файлов в веб-клиенте.

001.png

Теперь он позволяет выбирать несколько файлов перетаскиванием.

002.png

Он показывает название и размер выбранных файлов, а также позволяет отказаться от загрузки тех или иных файлов, исключив их из выбора.

003.png

Настройка диалога выбора файла

Теперь в методы НачатьПомещениеФайла() и НачатьПомещениеФайлов() вы можете передавать заранее настроенный диалог выбора файлов. Например, вы можете установить ему собственный заголовок, который более точно описывает то, какие файлы может выбирать пользователь.

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); Диалог.Заголовок = "Собственный заголовок диалога загрузки файла"; ОбработкаОкончанияЗагрузки = Новый ОписаниеОповещения("Обработчик_Завершения_Загрузки", ЭтотОбъект, Диалог); НачатьПомещениеФайла(ОбработкаОкончанияЗагрузки, , Диалог, Истина, УникальныйИдентификатор);

Контроль характеристик загружаемых файлов

Теперь, прежде чем загружать файлы на сервер, вы можете проверить их характеристики, например, размер. Если размер превышает допустимые значения, вы можете отменить загрузку.

&НаКлиенте Процедура ВалидацияПередОтправкойФайла(Команда) ОбработкаОкончанияЗагрузки = Новый ОписаниеОповещения("Обработчик_Завершения_Загрузки", ЭтотОбъект); ОбработкаНачалаЗагрузки = Новый ОписаниеОповещения("Обработчик_Начала_Загрузки", ЭтотОбъект); НачатьПомещениеФайла(ОбработкаОкончанияЗагрузки, , , Истина, УникальныйИдентификатор, ОбработкаНачалаЗагрузки); КонецПроцедуры &НаКлиенте Процедура Обработчик_Начала_Загрузки(ПомещаемыйФайл, ОтказОтПомещенияФайла, ДополнительныеПараметры) Экспорт ОтказОтПомещенияФайла = Ложь; Если ПомещаемыйФайл.Размер() > 5 * 1024 * 1024 Тогда ПоказатьПредупреждение( , "Размер файла " + "(" + ПомещаемыйФайл.Размер() + ") " + ПомещаемыйФайл.Имя + " (" + ПомещаемыйФайл.ИдентификаторФайла + ") превышает 5MB. Загрузка остановлена."); ОтказОтПомещенияФайла = Истина; КонецЕсли; КонецПроцедуры

Перетаскивание файлов на картинку и на таблицу

Теперь можно перетаскивать файлы на картинку или таблицу. Таким образом, например, вместо выбора фотографии сотрудника с помощью проводника пользователь может просто перетащить нужный файл на поле картинки.

004.png

Открытие файлов перетаскиванием

Теперь можно открывать файлы, перетаскивая их в веб-клиент.

005.png

Файлы будут открываться в рабочей области веб-клиента.

006.png

Рассказать друзьям: